Start a new topic

Firmware updating stops at 90%


I have problems updating, it always stops at 90% I already tried in all the recommended ways. Is there any problem on the servers?


3 people have this problem

Keep your device close to the router.

No that is not issue. May be some technical fault and not updating from server.

I am facing the same issue. Updates stops at 90%. Router is close by. Anyone got any luck in updating firmware from 1.8.1 to 2.6.0

I've got 8 devices 2 of them won't upgrade . Both stop at 90% Tried all the tricks, reset, turn off then on, close router, diff network. Just won't :(
I have the same issue on 3 devices. Has anyone managed to sort this issue?

Tengo el mismo problema en un T1 EU. Y en 2 basico lo mismo pero dejaron de funcionar. No funcionan los básicos, no encienden, no activan el rele.

check if you have connected input live and neutral wires properly. then if you have the firmware to 1.6.0 then use compatible AP mode by pressing the sonoff button for 5 secs and again for 5secs until you get fast bkinking green light. then update the device then dete it and add it again in simple touch mode... that will do the job :) follow the video below... https://youtu.be/iCRq5obr_SE

2 I have are stuck on 1.7.0

Method above does nothing to help updating .

I am now using them to remotely tun on/off table lamps.

They still work ok so nothing lost. 


i was also stuck and could not update. did you try connecting by pressing the button twice? i mean first there will be 2 short blinks and 1 long, dont connect to that, again press the button for 5 secs then green light flashes rapidly... then try connecting, it registers as first generation device .. then try updating... follow the video i posted above and try updating, it works

Thanks for replying again.

Yes I did what you did.

I have tried a few times. Some of my sonoff's work on the 1st press, others on the 2nd BUT for 2 units no upgrade.  An an aside some would only connect to one of my 2.4 ghz networks and not the other network I also have. Tablet is always connected to same network as switch.

As stated in earlier post they still work ok so will leave them be.

my S31 (US) is 1.0.0 and won't update to 2.7.0 


anyone else?


Login or Signup to post a comment