Start a new topic

Error adding Sonoff to server

Hi I ordered 7 Sonoff wifi switches but so far havent been able to add them to the server. The error is after the device name is entered and says " add failure". The light blinks twice fast like its connected to wifi but not to server. Router is operating correctly. please help!

16 people have this problem

I hope you are right Andrzej Konopacki and this is because of New Year and holidays. Seems that will be the best to flash the devices and have the own server :)

You must be patient.  server is in europe when you are in europe. working fast and good till yesterday.  Sometime you must clean memory in your phone when you see on your phone that  is not connection and you can not see light in sonoff device. Ifyou can see continous light in your sonoff  device and in your phone in ewelink you see that is offline it means that problems is in your phone -  close all aplications ,clean memory ,and then reopen ewelink aplication. It help. If still blinking your sonoff  device it means that problem is with server or your wifi home network. If your wifi is ok it means that problems is with server evelink and you can do nothing. I repeat you be patient becouse yesterday and today is realy problem with server and I belive that after New Year all come to good work and problems will be resolved.

Will see. Have been back online yesterday, but today again offline from morning. Not promising for now...

I'm another one with this problem. Can someone recommend me alternative to their Sonoff POW coz I don't have any more patience with them and their server problems.

 

This problem affects all Sonoff devices. I have had all 3 of my devices working fine for a few hours only to return to them and find the are stuck on two flashes. THIS IS A SERVER PROBLEM. The customer cannot change this and there is NO CURE. I am going back to TP-LINK devices which actually work! Sonoff devices can be re-flashed with different firmware that does actually work but this is a poor solution for non technical types who have bought these devices in good faith. These devices will apparently go on or off line with the server at random intervals and there is nothing the customer can do about it! In a distant future maybe there will be a way for the user to change the server used to one suitable and local enough to provide switching reliably. In the meantime buy another product. These devices are cheap but probably useless to most home automation applications. Technical support does not exist and certainly not for Europe. The replies given on this forum all say the same thing which DOES NOT WORK and con to solve the problem. Reflash the Rom with something that works and it’s not a bad switch.
Which TP-Link device would you recommend instead of Sonoff POW?

 

Personally I am using h100 plugs to feed multi-socket strips. The H200 light switch looks like a good lighting control if rather basic. I have one on order so I’ve not had a play with that yet! These are NOT CHEAP! But if they work well it may be worth the costs. I have 3 plugs and need 3 light switches to cover my control area. To get away from automating everything I have fitted LED PIR motion detector bulbs in the passageways of the house. Lights come on if someone walks in and go out again after a few minutes.
Hello, I have the exact same problem as bobbytod. I walked through the process as he did, but did not succeed. Can you please help me get the sonoff online?
Hi RJK Make sure you are using AP mode to connect to WiFi. Once connected locally (wi-fi) is EWeLink is showing the switch as offline switch off the device for about 10 mins. This gives time for the ITEAD server to update your account. Turn on again and see if it connects to both Wi-Fi and server. If not all you can do is delete the device and try again. Personally I moved some of my critical stuff to tp-link devices which seem more robust in connection.

Thanks for you answer. Unfortunately it does not work. Where and how do I delete the device? 

Buongiorno ho 5 moduli sonoff 3 funzionano benissimo , mentre mentre gli altri 2 dopo avergli eliminati dall'app eWelink non si riesce a fare l'accoppiamento.

Purtroppo l'accoppiamento dei sonoff è un tasto dolente. In alcuni casi ho perso parecchie ore per questa operazione. Pur seguendo tutti i suggerimenti da parte di ITEAD molte volte il problema restava. Ci vuole molta pazienza

It's amazing that they do not solve this problem.

I have another sonoff running for months correctly, now I have bought a new one, but, in the ewelink app, it always appears as "offline", while the other sonoff works correctly.

I can ping eu-disp.coolkit.cc without problems, I can connect to the new device sonoff from my phone's wifi, everything seems to be correct, but, the new device always appears as "offline" in my ewelink app and the device it is always with the double blinking that indicates that it does not connect to the server.

I registered an account just so I can help others on getting a Sonoff paired.


After trying for hours and using AP mode, pairing from fresh power up, trying to pair to WiFi without special characters in, pairing to a mobile phone hot spot, etc. etc.  The ONLY thing that worked STRAIGHT away, was to put the phone into airplane mode, then only activating the wifi to connect with home router, then running the app to pair, and it works!!

The system of putting the phone in airplane mode also tried it and it did not work for me.


Login or Signup to post a comment