Start a new topic

Can't share to email address

Ewelink ver 2.1.4 for iOS. You can not share a device to an email address. Only to a mobile phone number.

9 people have this problem

I have the same problem here.. I can't share the devices... Only I can control the devices at home and no one else. I have opened a ticket for the issue.

Well I got a response.  Basically "not our problem" use the feedback function in the app.  Which of course I did to begin with, had no response and thought I'd try here.   Next stop I guess it try them on Facebook.\

I'd recommend anyone who's experiencing a problem with sharing the switches from the eWeLink app to open a support ticket as well as commenting in this forum, hopefully if enough people raise the issue something will get done.  

It seems to be a problem that's affecting everyone, I even spent an hour figuring out how to get the WeChat Sonoff web interface to work (not easy if you don't read Chinese) It might be useful too as WeChat runs on a PC or Mac as well as mobile devices so you can control things from your computer too.  But even there I'm still getting the 'Does not exist' message.

So far I've had my support ticket open for a couple of days and nothing has happened other than an automated response acknowledging it.  I've also tried the eWeLink Facebook group without any response.  I'm guessing it's the time of year in my case, but as there's messages here on the same issue going going back three weeks I'm not exactly filled with optimism right now.  Also the lack of any response from them in that time would suggest that despite the title, the content posted here isn't being monitored by anyone.

I'm having the same problem. I'm able to control all devices from my eWelink app installed in my iPhone with my user id (email). My wife has two eWelink accounts (one with her email id and another with her phone number).

But, when I try to share the device to my wife's eWelink account, I get notification "does not exist". I tried both, phone and email. Why do I get this error even though her account exists!!

And why is there no solution yet? So many people are facing this problem.

Another one on IOS who is unable to share switches across accounts.  I've created several accounts using different emails but I'm unable to share any of the Sonoff switches as the app simply reports the accounts I'm sharing them to does not exist as detailed in the photos above.  Using the latest firmware IOS App, Please fix it's very tedious.

Please fix this email sharing issue! Nobody other than me can open my blinds! :(

1 person likes this

Doesn't solve it for email addresses ...

1 person likes this
Solved it! You cannot copy paste the telephone number. It has to be typed in fully.
Ewelink ver 3.1.5 for iOS. You can not share a device to an email address. From spain
(95.1 KB)
(60.5 KB)
(61.1 KB)



I also have a problem to share.

1st account , confirmed by telephone no. , iOS 3.1.5

2nd Account , Confirmed by telephone , Android 3.1.5

receive message invalid account.


I have the exact same problem as David. I click on share, then I put the email, the "waiting confirmation" message appears but my wife don't receives nothing either on the e-mail or this ewelink app.

2 people like this

Same problem. Using eWeLink 3.1.5 on Android.

My phone is paired with three Sonoff Basic devices, and works fine.

My wife's phone has the same eWeLink version on Android and her own eWeLink account, but with no devices paired.

I try to share one of my devices with my wife's account. I enter the country code (United Kingdom (+44)) and then the email address associated with her account. My phone shows "Waiting for response..." but no sharing notification ever appears on her phone.

Both phones are connected to the same home WiFi network as the Sonoff devices.

1 person likes this

Ewelink don't send me the verify code on email!!!!!!! And yes my is last version! This app don't work

iOS App Lets not put country, would have an update for the iOS App for iPhone 5c?
Login or Signup to post a comment