Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


25 people have this problem

i have the same trouble with several devices... indeed one of them (sonoff 4ch) it worked well, (testing), but when i place into final position (diferent wifi router)... it doesnt work, i can succesful pair, but after it... green light keeps blinking

 


1 person likes this
I have the same problem, except the unit is now 2 hours away. Has anyone resolved this issue as yet

 

I have exactly the same issue. I saw on YouTube a video from a guy, who shows nicely what the problem looks like: pairing problem.

Still no reply from support on this issue. Anybody there?

Tengo el mismo problema, el video explica claramente el error : 

I have the same problem, the video clearly explains the anomaly

https://www.youtube.com/watch?v=w_NHpFR_KqE


1 person likes this
I would love to know if there is a fix for this problem. I have the exact problem, it seems once the device has been paired to an access point it refuses to be paired to a new access point. When I tried pairing it back to the original router it works first time! It would be great if there was a factory reset option. Any help with this issue would be greatly appreciated. Regards, Jon.

3 people like this

I also have the same problem. Sonoff 5V 1ch inching PCB has previously registered ok but after a few months of being powered off, no longer works.  I can discover and pair the device in ewelink app and provide the wifi details and it comes back as registered successfully but it will not connect to my wifi. Have tried different wifi networks. Syslogs from my APs show the device doesn't even attempt to connect i.e. not a case of incorrect credentials. A solution would be great. Regards Stuart.


1 person likes this

I have connection to device problem after pairing also. I think its time that Itead give us a working solution or simply tell us the that switches with this problem are now scrap!

Exact same problem as Abel shows in his YouTube clip, unbelievably frustrating! Any gurus found a fix?
Just a thought, if my 4ch pro no longer works on my network, how about we exchange units with others so at least we can get value out of them as a temporary work around.
I finally managed to get mine working... I decided to have one last attempt at trying to pair it. I first tried connecting it to another access point (which didn't work) and then reconnected it to the original AP which worked! I have no idea why I'm afraid as I had tried numerous different access points in the past with no luck. It had been powered down for a fews day prior to me trying again so maybe that helped? It might be worth leaving them powered down for a few days and then trying again... if all else fails I'm liking Ian's idea!
I have the same problem. Pair but not connect to router. Try and another router, nothing. Try and another phone, nothing. Try to delete and add again, nothing. Try to let it off for a day, nothing.....
When I get home im going to delete my E-we link account and devices off my phone and start from scratch using a new account to see if that works, my logic is that the problem is at the server end, not phone or router.
Login or Signup to post a comment