Start a new topic

Sonoff Switch Pairs but will not connect to WiFi

After Successful pairing and Renaming the device it does not connect to wifi and Green light keeps blinking, tried to delete and repair but no luck.

One device is connecting and another - Does not.... :( 


28 people have this problem

Thanks for the advice kevin.. unfortunately my orbi doesnt like to work with sonoff, or me for the record.. Now the device says I must use 2.4ghz. I've tried to go into my Orbi and try to set channels, auto channels, re position of router and Satellite, and still not working.

My device had the exact same problem after upgrading my modem/router, and I tried everything suggested here on this forum, wasting 7 hours yesterday.  Giving up, I ordered a new device from another manufacturer last night.  However, I finally got my old device working this morning, so I joined this forum just to explain.  I deleted the device from ewelink app again, but this time I chose the menu option to scan the QR code, which I found on the original box.  The app scanned the code, and tried to process it, but failed with "Invalid QR code".  I tried this multiple times.  I gave up on QR code idea, and simply tried pairing the same way I already did dozens of times yesterday.  Unbelievably the device connected normally after paring and registering.  Therefore, one of these things made the difference:  1) scanning the QR code somehow reset something on their server?  2) waiting 24 hours before trying again somehow reset something on their server?  3) their server somehow detected that I had ordered a better device and decided to cooperate before I threw their old device in the trash?  My story is #3 and I'm sticking to it =-)

@D McMullan, What kind of router are you connecting too? I am using netgear orbi50 with orbi Satellite. It's hard for me to designate a 2.4 channel to directly connect. My current situation is when trying to connect, so off says it will not connect to 5 only 2.4,,,,, here we go again.
Fortunately for me, my new Netgear AC1750 allows me to name the SSID for 2.4 differently than the SSID for 5, so they both show up in the list of detected Wi-Fi, therefore I can choose either one depending on the device I'm pairing. Of course for the ITEAD switch device, I chose the SSID for 2.4.

The problem is underscores in the ssid, once you remove the underscore you will be able to connect, also do not have spaces in the name, my old ssid was ASUS_88U_2G and i was unable to connect, once changed to ASUS88U2G i connected straight away.

The only thing my sonoff switch will connect to is my ATT Pace modem and I tested it with 2 different models of those and it worked with both.  If you need more help I recommend visiting the Netgear Support team.

Alas! I am having the same problem. Started a ticket. My SSID has no underscores. But id does have a dash. I'm not going to change it because that means I have to connect everything again.

Switching from AES to TKIP fixed the "Device Offline" issue. Now I'm able to upgrade the firmware from 2.0.1 to 2.6.0. Ill try to switch back to AES after upgrading.

funnily i managed to do the firmware upgrade after many times of failure. I succeeded by making sure my phone is very far away.

I have exactly the same issue too. Any new suggestions?

Hi, i make same new test, as i have wrote i use some tenda AP in specifics:
 jknet3: a old N301 with old firmware V5.07.55_en_FOR01
  works with SONOFF TH16
 jknet7: and a newer N300 with recent firmware (i have 2 of this one in the place i have to use (jknet4) and another here near my computer for tests (jknet7)) this newer works with sonoff pow that is running now and not with sonoff th16.
The jknet7 and jknet4 and other are connected to jknet3 directly(cable) or with hub(cable), jknet3 is connected to inernet.
my computer is connected directly to jknet3 with ethernet cable.

Now i have a tp-link tl-wn422g i connect to my computer it and i configure as jknet7 same password of real jknet7 (the password is 13 characters)
I turn off the tenda N300 jknet7
i start (i use ubuntu 18.04):
 sudo tcpdump -i wlan0 -vv -e
to see what happen on the lan

When i reset sonoff don't appear nothing!
 Strange, i'm make some wrong?
 Why no transmission?

If i connect with it using an android phone i get this, and other but i stop:

08:55:13.790034 00:27:2c:7b:7e:cd (oui Unknown) > Broadcast, 802.3, length 6: LLC, dsap Null (0x00) Individual, ssap Null (0x00) Response, ctrl 0xaf: Unnumbered, xid, Flags [Response], length 6: 01 00
08:55:13.796389 00:27:19:ba:68:46 (oui Unknown) > 00:27:2c:7b:7e:cd (oui Unknown), ethertype EAPOL (0x888e), length 113: EAPOL key (3) v2, len 95
08:55:13.806109 00:27:2c:7b:7e:cd (oui Unknown) > 00:27:19:ba:68:46 (oui Unknown), ethertype EAPOL (0x888e), length 135: EAPOL key (3) v1, len 117
08:55:13.806241 00:27:19:ba:68:46 (oui Unknown) > 00:27:2c:7b:7e:cd (oui Unknown), ethertype EAPOL (0x888e), length 217: EAPOL key (3) v2, len 199
08:55:13.811850 00:27:2c:7b:7e:cd (oui Unknown) > 00:27:19:ba:68:46 (oui Unknown), ethertype EAPOL (0x888e), length 113: EAPOL key (3) v1, len 95
08:55:13.911614 00:27:2c:7b:7e:cd (oui Unknown) > 33:33:ff:7b:7e:cd (oui Unknown), ethertype IPv6 (0x86dd), length 78: (hlim 255, next-header ICMPv6 (58) payload length: 24) :: > ff02::1:ff7b:7ecd: [icmp6 sum ok] ICMP6, neighbor solicitation, length 24, who has fe80::227:2cff:fe7b:7ecd
08:55:13.911636 00:27:2c:7b:7e:cd (oui Unknown) > 33:33:ff:7b:7e:cd (oui Unknown), ethertype IPv6 (0x86dd), length 78: (hlim 255, next-header ICMPv6 (58) payload length: 24) :: > ff02::1:ff7b:7ecd: [icmp6 sum ok] ICMP6, neighbor solicitation, length 24, who has fe80::227:2cff:fe7b:7ecd

I read about the code and are pachet for authentication.

Some ideas or new tests?
Roberto

 

 Hi i have make an analisys for better chomprension:
situations:
1) in this situation it is connected to jknet3, working, i start these command and then i connect the power plug to sonoff
i setup my wireless lan of the computer in monitor mode using:
 sudo airmon-ng start wlan0 6
   where wlan0 is my interface connected at the computer anc 6 is the channel used by the AP.
Then i start tcpdump for save radio packets:
 sudo tcpdump -i wlan0mon -vv -e |grep 20:ce:fc >sonoff_jknet3.txt

2) now i reprogram it for connecting with jknet7
stop interface
 sudo airmon-ng stop
check ifconfig if it is down, to be sure i remove the wifi(usb) and replug
 ifconfig
restart other channel 11 is jknet7
 sudo iwconfig wlan0 channel 11 (need?)
 sudo airmon-ng start wlan0 11
 sudo tcpdump -i wlan0mon -vv -e |grep 20:ce:fc >sonoff_jknet7b.txt
   (i have 2 file 7 in programming time and 7b post programmed at plug off ond on)

files:
sonoff_jknet3.txt working start procedure + ping
sonoff_jknet7.txt not working at programming time
sonoff_jknet7b.txt not working at start procedure

Info about the file 5e:cf:7f:20:ce:fc is the sonoff the other the APs
In the jknet3 file at the end i try to ping it, ping 192.168.1.102
To check the channels i use WiFiAnalize free on playstore (open source)

I'll analize files in a better way i hope some one can help me, wifi networks are not my speciality.

Roberto.


txt
txt
txt
I had the same problem and I found out what it was. My 2.4GHz network was set to g+n only. When I switched it to b+g+n on my router it worked. I think many newer routers at set to not use the older b mode.
Login or Signup to post a comment