Start a new topic

Sonoff RF bridge doesn't learn remote buttons, always times out

I'm trying to get the Sonoff Bridge to learn remote codes from this remote APA3-1500R. This remote is operating at 433.92MHz

The bridge goes into learning mode, I hear a beep and the red led is flashing. However, I try many times to learn different buttons, but it always fails after one minute with a timeout error.

This way the bridge is useless to me. I'm following the instructions closely. Is there a way to fix this? Can you release a firmware update?



55 people have this problem

Ok. This has two issues and this is what worked for me. To learn a device or another device unplug bridge, leave for 15 seconds, plug, wait for steady blue led and learn the device. If it still doesn't learn, unplug, wait replug and learn again with the bridge right next to the device. The bridge has VERY POOR reception. It does not detect all my window/door sensors of the ground floor where the brudge is located. Will open it up one of these days and solder an external antenna, will see if it makes any difference.

Does not matter whtat you do. I have mine die over and hover. A heat problem. it lasts and hour then looses its mind. bad design. End of story; they told me design isssue so don't bother trying to get it to work ! 

Well, mine works a lot better. For over 1 year continuously, 2 window open/closers (so 4 signals), door alert, smoke alert. Learning all these devices without heistation, but learning was done next to the device and only thereafter the device was plugged in somewhere else.

There is difficulty in connecting with non-Sonoff devices, I noticed too.

I have the same problem... can not learn the RF: RMC610/433.92Mhz (CE0681) ( or other RF)...

Way? What can I do?

Mauro said the right thing, it's more abour the code and the chip in your  remote than about the frequency. From my remotes bought in Europe none works. From those bought in Asia (Aliexpress) 90% works. Now I have a door sensor, a smoke detector and two 2-channel window motors running without any problem.

Thanks for sharing such an amazing blog. Tried sliding the switch on and off a few times again today and the unit now learns the keyfob codes, so I know it's able to learn.

Login or Signup to post a comment