Start a new topic

No wifi autoreconnection in case wifi signal lost

when the wifi signal of home lan is lost for some reason and then re-established... the sonoff cannot automatically reconnect to the wifi! the only way to reconnect is to reset the sonoff. Is it a problem with my sonoff only or is it a general problem that should be addressed by a firmware upgrade (eg enhancement the sonoff firmware with an autosearch for wifi feature in case wifi connection is lost)?

3 people have this problem

 

am looking for a solution for my wifi protocol i search a lot in the forum

مناطق اسطنبول 

I used to have many such problems when I was using TP-Link Archer AX11000 router but I did not have any problem after I fixed the router. I suggest you get a new wireless router .



am looking for a solution for my wifi protocol i search a lot in the forums

Autooconnect might not work because of the bug issues. I guess you can do it by re-starting the app. Help with essay

hi

update: it's not 3 fast blue blinking+1 slow. it's 2 blue fast + 1 slow. in other words each third blinking is slow :-) . That's a SONOFF T1 (switch in the wall)

static IP is not the solution. No idea why it would be based on the way the communication goes.


anyways, all my SONOFF have a static IP. they work well, suddenly, they disconnect from WIFI connexion (1 meter from the internet box), they will NOT reconnect automatically. 

They do NOT appear anymore in my internet box, the blue light is blinking fast 3 times, then 1 time slow, and it repeats that cycle forever..

I have to re-appair, then it works, a few minutes, then it does not work anymore after a few minutes.


it's definitely on 2.4Ghz, no 5 enabled.


THe firmware was 1.6 (!) and being migrated to 3.3, but does not help.

I have only 1 SONOFF that NEVER disconnect (it has 3.0).

i'm wondering about upgrading this one to 3.3 to see if that's firmware issue.

any other ideas?


Rod



The solution is what "Stephen Bunting" said. You need to give it a static ip address from your DHCP server in your router. Be careful to make sure to change the range of the other devices as described by "Stephen Bunting" in a previous comment. 

Hello.


My sonoff t1 U.S. with firmware 2.7.1 also disconnect.


Sometimes I open the ewelink app to power on/off the light, but the app shows that sonoff T1 is offline. after about 2 minutes the sonoff reconnects. 

The sonoff is about 2 meters of distance of the router.

As far as I know, the firmware cannot be to downgrade.

 

Good morning, The problem is not in eWelink software, as I have two sonoff Touch US one with firmware 3.0.0 that loses the connection and crashes and the other with firmware 2.6.1 and works great. Is it possible to revert the firmware update?

the problem is not in the firmware but in the new version of eWelink. The last one is 3.5.8

I have the same problem with the instalation firmware 3.0.0.

I have been having this issue since I installed 3.0.0 firmware to my Sonoff T1 EU 1C switch.

If I plug off my Wi-Fi on the outlet and plug in again then T1 switch cannot reconnect to my Wi-Fi. I have to delete T1 switch from the ewelink app and pair it again. It is very frustrating.

Could you help someone how can I solve this problem?

Login or Signup to post a comment