Start a new topic

Sonoff switches won't connect

I've upgraded my router, and discovered that none of my devices will now connect to the new one, in Quick pairing mode it won't discover them, and in AP mode, it will discover the devices, but they won't connect, how do I get around this?

2 people have this problem

Just out of curiosity, is yours a mesh network?

Nope, it isn't

Turn on airplane mode and connect using quick pairing mode (touch).

I can't connect the sonoffs switchs to Wi-Fi. I verified the "10 Solutions to Failed to Connect to the WiFi Router" but the problem persist. I used de pairing proccess and de devices are defined but the status is off line. Do you sugest me another process?

If you cannot connect your device this is due to old first generation hardware that doesn’t work properly with new internet devices because of SSID and PWD combination.

This worked for me with my Android phone in combination with an ASUS RT-AC87U

Create guest network  and name SSID: 12345678 with PWD: abcabcab

Press button on socket 2x 7 seconds in order to let it blink every second.

Pair the device (don’t use compatible AP). After connection update firmware.

Leave the device on for 5 minutes and unplug the socket.

Remove the guest network with SSID: 12345678 and connect with your phone to you own network again. Plug the socket back to the wall plug and press the button on the socket 1x for 7 seconds until it blinks every 3 seconds. On the app select now Compatible Pairing Mode AP.

Now you will see that the device has been recognized as second generation.


Took some time to figure it out but it worked.



1 person likes this

I was not able to connect my device.  Here is what finally worked for me with an Android phone.  I put the phone in airplane mode, then turned on only wifi (but left phone in airplane mode).  Finally I was able to use the standard method and connected the first time.

I found that the failure to pair is device-specific.  From my Android phone I tried different ways of pairing, using different wifi and routers, and it never paired.  I did the same with my Android tablet using the same wifi and router and it paired the first time.  Once the device registered it updated the firmware.  That may have resolved the problem but I wasted so much time trying to pair I'm not going to try it again.

I can view the device with my phone every time and I've not had any similar problems with this phone.  Sonoff just doesn't want to work with it.  BTW it's a Samsung S7

Thank you Mr Nemo, your procedure finally got my Sonoff switch working again! It had been inoperative for 6 months since I upgraded my router Thanks again Steve

I have the same issue but have been unable to fix it. All of my devices upon pairing turn on whe adHoc AP but it only lasts 7 seconds and then disappears. 

Thanks Mr Nemo. Your suggestion worked : 1. create new guest network with simple SSID/Password , 2. enter setup mode with 2 x 7 seconds hold, 3. update firmware. 

I managed to then reconnect to one of my permanent SSID's. 

However, I still could not connect to one of the another SSID's on a separate router. Still not sure if it is down to the Router or the fancier SSID name. Could older Sonoff's not like fancy characters ?

Mr Memo's procedure does not work for me. I created 2.4 GHz access point with name and password as suggested. I connected my phone (Galaxy note 9) to this network and started the pairing procedure but that did not work.

Did I do anything wrong? It was not mentioned above if you need to connect your phone to the "12345678" or is there some other method.

I have the same issue with T0 EU TX. Nothing helps :(. I have tried all scenarios you have shared and none of them is working :(

I found a solution for this. I think this issue appears in Android 10. Anyways here the solution.

1. Press the "+ " icon for to add a new device

2. Scroll to the bottom of the screen and look for "Comatible mode >" and press.

3. Press next. You will see the details of you access point. Enter you access point ssid and password.

4. Click next. You will see "Searching for device AP."

5. Go to your wifi settings (you will not be redirected from the ewelink app, just go there). Select ITEADxxx network. The password in "12345678" ( I hope I am not mistaken with respect to the password, I did it a while ago but if this is a wrong password I'd be happy if someone who found this beneficial can update).

6. return to ewelink and complete the pairing

Eli, this was my first solution. I'm familiar with compatible pairing process. It won't work. I was able to pair it using my old LG Nexus phone.

Login or Signup to post a comment