Start a new topic

Can't relink eWeLink Smart Home to Google Home


I unlinked my eWelink account from Google Home, but cannot relink it. It keeps saying 'Google home couldn't update the setting. Check your connection.'

Tried everything that Google suggested. Delete cache, reinstalled all apps, tried on different device, different browser, unlinked everything from my google account. 

It seems like something is wrong with the authorisation server from eWelink, as if it doesn't properly unlink my account? Anyone with tips?

Kind regards and thanks a lot!


2 people have this problem

The same problem happens to me. Any solution?

Same here stopped working from GH Disconnected and now can't be reconnected
It's already working again, I've already been able to link the account to the Google Home App
Same problem. After getting a new router, can't link in newly reloaded Sonoff devices/account into G Home. I've tried everything... Deleted both apps, cleared cache, deleted Homes, switched accounts, unlink security settings. Very frustrating. Help!
Login or Signup to post a comment